cPanel Versjon 84
Skrevet av: Simon A. Skaar

Kraftigere forbedringer til AutoSSL, PHP 7.3 på servernivå og oppusset grensesnitt for webmail er noen av nyhetene i denne versjonen

Fra denne versjonen vil AutoSSL bli kjappere utstedt da valideringen kjøres for alle DNS-postene samtidig, det blir også kjørt validering umiddelbart når man oppretter eller endrer DNS-poster. Før dette ble kun en og en post validert, noe som resulterte i tregere validering.

cPanel kjører nå på PHP 7.3 på servernivå (fra vår side), dette gir raskere og tryggere opplevelse når man er inne i cPanel og utfører endringer.

PowerDNS og DNSSEC sørger nå for å forhindre angrep via DNS (spoofing, Man-in-the-Middle Attacks). Dette ble informert om i oktober på cPanels blogg. Før dette ble bind benyttet, denne blir nå faset bort og byttet ut med PDNS DNSSEC og PowerDNS.

I webmail er det nå kommet flere valg for brukerene hvor hver bruker kan administrere alt fra innboksen til kontaktinformasjon og spamfilter for sin egen konto. Det er også lettere å hente ut informasjon for å sette opp kontoen på ulike enheter og e-postapplikasjoner.

Error-log viser nå de 300 siste linjene for suexec_log og error_log
Her får du nå informasjon fra rotmappen og suexec_log filen som har feilmeldinger relatert til kontoen din. Verdt å sjekke når du er inne i cPanel neste gang.

Denne versjonen er allerede lagt inn på de fleste serverene og funksjonene er klare til å benyttes.

Hva er nytt i cPanel versjon 76
Skrevet av: Morten Malde

Våre hosting servere kjører versjon 74 av cPanel og denne uken vil samtlige servere bli oppgradert til versjon 76. Det er ikke store endringer i denne oppgraderingen, men noen endringer er verdt å merke seg.

Nytt «domene» oversikt ikon

Det vil komme ett nytt ikon i cPanel som viser bedre oversikt over domener knyttet til webhotellet. Hvis du har flere tilleggsdomener på webhotellet så vil dette ikonet være veldig nyttig. Du kan velge hvilke mapper de forskjellige domenene skal peke til og du kan gå direkte til epost opprettelse for domenenavnet.
Dette kunne du også gjøre før, men det er nå forenklet for deg.

Nytt ikon i cPanel

Intern PHP i cPanel oppgraderes

cPanel vil oppgraderer PHP fra 5.6 til 7.2. Ut fra våre tester så er det merkbar forskjell i hastigheten inne i selve cPanel. Navigeringen og responsen har blitt betydelig raskere og bedre.

PHP 5.6 til PHP 7.2

SquirrelMail fjernes i versjon 78

På nye servere med versjon 76 så finnes ikke lengre webmail programvaren Squirrelmail. Fra neste versjon (78) så vil Squirrelmail også forsvinne fra våre eldre servere. I hovedsak er dette grunnet sikkerhetsmessige årsaker. Du kan lese mer om dette i «The death of SquirrelMail».

Squirrelmail blir fjernet fra cPanel

Benytter du utdatert PHP versjon?
Skrevet av: Isabelle

Innen utgangen av 2018 vil utviklingen av PHP 5.6 og 7.0 avvikles. Dersom du benytter disse versjonene i dag bør du oppgradere til en nyere PHP-versjon. Dette for å sørge at nettsiden din fortsetter å virke, forblir rask og sikker.

Hva er PHP?

PHP er forkortelsen for Hypertext Preprocessor. Det er et skriptspråk som kjører på webservere for å lede nettsteder med dynamisk innhold (søkemotorer og blogger for eksempel).

Sørg for at nettsiden er kompatibel

Oppgraderingen fra 5.6 til 7.x skal fungere uten problemer, men vi anbefaler at du sjekker programkoden for din nettside for å være sikker.

Det du gjør er følgende:

  • Sjekk at den nyeste versjonen av skriptet ditt (for eksempel WordPress/Joomla/OpenCart) er installert på ditt webhotell.
  • Sørg for at alle temaer og tillegg som du benytter er oppdatert og kompatibelt medversjon 7.x. Dette skjer ikke alltid automatisk, men dersom du har oppdatert tilleggene dine det siste året, er de mest sannsynlig klar for versjon 7.1+. Kontakt din webutvikler og spør dersom du er usikker på om nettsiden/skriptet ditt er kompatibelt med nyere versjon.
  • Veiledningene nedenfor inneholder sjekkpunkter du bør gå gjennom for å sjekke at nettstedet ditt er klar for oppgradering til 7.x.

cPanel sin PHP-selector viser her extensions

Oppgradering fra 5.6 til 7.0
Oppgradering fra 7.0 til 7.1
Oppgradering fra 7.1 til 7.2

Dersom du har programmert nettsiden  med mysql_* -funksjonene, må du bytte dem til mysqli eller PDO. Hvis du har en nyere versjon av WordPress/Joomla/OpenCart, bruker du allerede riktige databaserforbindelser.

*PRO ISP støtter alle PHP-versjoner, selv om noen av disse avvikles.

Hvordan endrer du PHP-versjon?

Guiden «Sette PHP versjon for webhotell i cPanel» vil vise deg hvordan du endrer PHP-versjon. Du kan endre denne når du vil via cPanel.

OBS: Denne artikkelen kan være utdatert og du bør se etter siste versjon da vi alltid anbefaler å benytte så nye versjoner som mulig for bedre hastighet og sikkerhet.