PHP mail charset og norsketegn feil hos ProISP

6 innlegg i emnet

Hei, Jeg sender epost med PHP og har utfordringen hvor de norsketegnene viser som rare tegn i eposten. På min gammel server brukte jeg php skript hvor jeg lagde i header "charset=iso-8859-1" og den fungerer helt fint...perfekt faktisk, på mobil, gmail, outlook. Jeg prøvde å bruke samme skipt på PRO ISPs server med det viser helt feil. Jeg endret charset til charset=UTF-8 og det nesten fungerer. Den viser riktig i Gmail, og Outlook men ikke på mobilen. Min gammel server var Apache. Jeg lurer på om det er stor forskjell mellom denne serveren, CGI Fast, og Apache...eller er det noe jeg må endre i php.ini filen. Takk!

Del dette innlegget


Lenke til innlegg
Del på andre sider

Hei, Kunne du ha limt inn headeren fra en eksempel epost slik at vi kan se om vi ser noe der? Encoder du teksten som sendes med utf8_encode()? Antar at teksten er iso-8859-1 i utgangspunktet.

Del dette innlegget


Lenke til innlegg
Del på andre sider

Hei, Er filen i UTF-8 charset? Eller henter du data som allerede er UTF-8 fra database f.eks.? Er det både tittel og innhold du opplever dette for?

Del dette innlegget


Lenke til innlegg
Del på andre sider

Tusen takk, det var veldig vanskelig å finne hva charset filen var, særlig i .php filene men de var UTF-8. Jeg har endret disse og nå det fungerer!! Takk

Del dette innlegget


Lenke til innlegg
Del på andre sider

Hei, Flott! Bare hyggelig ;)

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!


Start en konto

Logg inn

Har du allerede en konto? Logg inn her.


Logg inn nå