Benytter du utdatert PHP versjon?
Skrevet av: Isabelle

Innen utgangen av 2018 vil utviklingen av PHP 5.6 og 7.0 avvikles. Dersom du benytter disse PHP-versjonene i dag bør du oppgradere til en nyere PHP-versjon. Dette for å sørge at nettsiden din fortsetter å virke, forblir rask og sikker.

Hva er PHP?

PHP er forkortelsen for Hypertext Preprocessor. Det er et skriptspråk som kjører på webservere for å lede nettsteder med dynamisk innhold (søkemotorer og blogger for eksempel).

Sørg for at nettsiden er kompatibel

Oppgraderingen fra 5.6 til 7.x skal fungere uten problemer, men vi anbefaler at du sjekker programkoden for din nettside for å være sikker.

Det du gjør er følgende:

  • Sjekk at den nyeste versjonen av skriptet ditt (for eksempel WordPress/Joomla/OpenCart) er installert på ditt webhotell.
  • Sørg for at alle temaer og tillegg som du benytter er oppdatert og kompatibelt med PHP 7.x. Dette skjer ikke alltid automatisk, men dersom du har oppdatert tilleggene dine det siste året, er de mest sannsynlig klar for PHP 7.1+. Kontakt din webutvikler og spør dersom du er usikker på om nettsiden/skriptet ditt er kompatibelt med nyere PHP versjon.
  • Veiledningene nedenfor inneholder sjekkpunkter du bør gå gjennom for å sjekke at nettstedet ditt er klar for oppgradering til 7.x.

Oppgradering fra 5.6 til 7.0
Oppgradering fra 7.0 til 7.1
Oppgradering fra 7.1 til 7.2

Dersom du har programmert nettsiden  med mysql_* -funksjonene, må du bytte dem til mysqli eller PDO. Hvis du har en nyere versjon av WordPress/Joomla/OpenCart, bruker du allerede riktige databaserforbindelser.

*PRO ISP støtter alle PHP versjoner, selv om noen av disse avvikles.

Hvordan endrer du PHP-versjon?

Guiden «Sette PHP versjon for webhotell i cPanel» vil vise deg hvordan du endrer PHP-versjon. Du kan endre PHP versjon så mye du vil via cPanel.

 

Facebooktwittergoogle_pluslinkedin

2 thoughts on “Benytter du utdatert PHP versjon?”

  1. Hei! Vi bruker WP 2014 tema, og dette har blitt jevnlig oppdatert. Ingen tillegg. Dels fordi vi ikke har behov for det, men også for å unngå evt problemer. Må vi da gjøre noe med PHP-versjonen?

Legg igjen en kommentar

Din e-postadresse vil ikke bli publisert. Obligatoriske felt er merket med *